CVE-2026-67411

RabbitMQ: Web MQTT with PROXY Protocol enabled: a loopback-only user permission bypass

HIGH
7.1
CVSS Score
Published: September 25, 2026 at 04:26 PM UTC
Updated: October 8, 2026 at 04:46 PM UTC
2 products affected across 2 vendorsRabbitmq ServerRabbitmq Server

Using rabbitmq-server by rabbitmq?

Get instant alerts when new vulnerabilities affect rabbitmq-server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.1
Exploit prediction
EPSS 0.3%
SSVC
PoC

Description

RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.18, 4.0.23, 4.1.14, 4.2.9, and 4.3.3, native MQTT and MQTT over WebSocket behind a trusted PROXY Protocol frontend could lose the proxy-derived client address before the MQTT authentication path checked loopback_users, causing the frontend-to-broker address to be treated as loopback. An attacker who can reach the trusted frontend and has valid credentials for a loopback-restricted account can therefore bypass the source-address restriction; the issue does not bypass password authentication. This issue is fixed in versions 3.13.18, 4.0.23, 4.1.14, 4.2.9, and 4.3.3.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.13.0 ≤ v < 3.13.184.0.0 ≤ v < 4.0.234.1.0 ≤ v < 4.1.144.2.0 ≤ v < 4.2.94.3.0 ≤ v < 4.3.3*
Affected range stops below 3.13.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.13.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.3, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card