CVE-2026-67406

RabbitMQ: Federation and Shovel Gen-Servers Lack format_status Callback — Plaintext Credentials Exposed in Crash Dumps and sys:get_status

MEDIUM
6.5
CVSS Score
Published: September 25, 2026 at 04:34 PM UTC
Updated: October 16, 2026 at 04:16 PM UTC
2 products affected across 2 vendorsRabbitmq ServerRabbitmq Server

Using rabbitmq-server by rabbitmq?

Get instant alerts when new vulnerabilities affect rabbitmq-server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.3.3, 4.2.9, 4.1.14, and 4.0.23, Shovel does not format state logged by the crash reporter and can leave unencrypted credentials in a crash dump file. the shovel worker genserver processes does not implement the formatstatus/2 callback. When these processes crash (e.g., due to network partitions, connection failures), the OTP SASL error handler writes the full process state , including plaintext AMQP passwords and URIs , to the error log. This is particularly severe for the shovel worker, which stores deobfuscated plaintext URIs (including amqp://user:password@host format) in its genserver state for the entire process Automatic Credential Exposure: Shovel worker crashes (common during network partitions) automatically write plaintext upstream/downstream passwords to error logs No Special Configuration Needed: Unlike DEBUG logging, SASL error reports are always active Broad. This issue is fixed in versions 4.3.3, 4.2.9, 4.1.14, and 4.0.23.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.0.0 ≤ v < 4.0.234.1.0 ≤ v < 4.1.144.2.0 ≤ v < 4.2.94.3.0 ≤ v < 4.3.3
Affected range stops below 4.0.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_CONFIRMVendor AdvisoryExploit
Source: cverecord
https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-q44f-9vc5-grh7
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.9
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.3

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-200

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card