CVE-2026-6739

Mattermost: Delegated admins could patch protected default system roles

HIGH
7.2
CVSS Score
Published: June 12, 2026 at 03:49 PM UTC
Updated: June 18, 2026 at 03:45 PM UTC
2 products affected across 1 vendorMattermost ServerMattermost

Using Mattermost by Mattermost?

Get instant alerts when new vulnerabilities affect Mattermost - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 fail to require system-level permission when patching protected default system roles, which allows authenticated users with delegated user-management permissions to escalate privileges by altering built-in role permissions via the role patch API.. Mattermost Advisory ID: MMSA-2026-00656

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.11.0 ≤ v < 10.11.1711.5.0 ≤ v < 11.5.511.6.0 ≤ v < 11.6.2
Affected range stops below 10.11.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.5.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.6.2, so it looks safe — our inference, not a vendor statement
10.11.0 ≤ v ≤ 10.11.1510.11.0 ≤ v ≤ 10.11.1611.5.0 ≤ v ≤ 11.5.411.6.0 ≤ v ≤ 11.6.110.11.011.5.011.6.0
Vendor states this is fixed in 10.11.16 (unaffected)
Vendor states this is fixed in 10.11.17 (unaffected)
Vendor states this is fixed in 11.5.5 (unaffected)
Vendor states this is fixed in 11.6.2 (unaffected)
Vendor states this is fixed in 11.7.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

Vendor Advisory
Source: cverecord
https://mattermost.com/security-updates

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card