CVE-2026-67338

JupyterLab before 4.5.9 Stored XSS via Extension Manager

MEDIUM
6.1
CVSS Score
Published: August 1, 2026 at 12:22 PM UTC
Updated: October 8, 2026 at 04:17 PM UTC
2 products affected across 2 vendorsJupyterlabJupyterlab

Using jupyterlab by jupyterlab?

Get instant alerts when new vulnerabilities affect jupyterlab - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the JupyterLab origin when users click the extension name.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.5.9
Affected range stops below 4.5.9, so it looks safe — our inference, not a vendor statement
0 ≤ v < 4.5.90
Vendor states this is fixed in 4.5.9 (unaffected)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.1MEDIUMVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-84

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card