CVE-2026-67336

better-auth before 1.6.11 Insecure Cryptographic Defaults via oidcProvider

HIGH
8.7
CVSS Score
Published: August 1, 2026 at 12:22 PM UTC
Updated: September 8, 2026 at 08:49 PM UTC
2 products affected across 1 vendorBetter Auth /oauth ProviderAuth Better Auth

Using better-auth by better-auth?

Get instant alerts when new vulnerabilities affect better-auth - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.7
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

better-auth versions before 1.6.11 contain insecure cryptographic defaults in the oidcProvider and mcp plugins that advertise the none algorithm and accept plain PKCE by default. Attackers can exploit algorithm negotiation to accept unsigned tokens or intercept authorization codes when PKCE plain is used instead of the required S256 method.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.6.11
Affected range stops below 1.6.11, so it looks safe — our inference, not a vendor statement
v < 1.6.11
Vendor states this is fixed in 1.6.11 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.7HIGHVulnCheck
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-327

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card