CVE-2026-67335

better-auth before 1.6.2 OAuth State Validation Bypass

MEDIUM
5.3
CVSS Score
Published: August 1, 2026 at 12:22 PM UTC
Updated: September 8, 2026 at 08:49 PM UTC
2 products affected across 1 vendorBetter Auth /oauth ProviderAuth Better Auth

Using better-auth by better-auth?

Get instant alerts when new vulnerabilities affect better-auth - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

better-auth versions before 1.6.2 fail to validate the OAuth state parameter against the stored nonce when using cookie-backed state storage without PKCE. Attackers can forge the state parameter and supply an attacker-controlled authorization code to create authenticated sessions bound to the attacker's external identity or persistently link attacker accounts to victim profiles.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.6.2
Affected range stops below 1.6.2, so it looks safe — our inference, not a vendor statement
v < 1.6.2
Vendor states this is fixed in 1.6.2 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.3MEDIUMVulnCheck
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-287

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card