CVE-2026-67327

better-auth before 1.6.22 Account Takeover via Magic-Link Email-OTP

HIGH
8.3
CVSS Score
Published: August 1, 2026 at 12:22 PM UTC
Updated: September 8, 2026 at 08:49 PM UTC
2 products affected across 1 vendorBetter Auth /oauth ProviderAuth Better Auth

Using better-auth by better-auth?

Get instant alerts when new vulnerabilities affect better-auth - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.3
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

better-auth versions >= 1.1.3 and < 1.6.22 (and pre-release versions >= 1.7.0-beta.0 and < 1.7.0-beta.10) are vulnerable to account takeover via pre-account hijacking on magic-link and email-OTP sign-in when open email/password registration is enabled. An attacker registers an account with the victim's email address and an attacker-chosen password; the account remains unverified. When the legitimate owner later signs in via the magic-link or email-OTP passwordless flow, the account is marked verified without removing the pre-existing password or revoking existing sessions, so the attacker's password remains valid, granting persistent access to the victim's account. Fixed in 1.6.22 and 1.7.0-beta.10.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.7.01.1.3 ≤ v < 1.6.22
Affected range stops below 1.6.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.7.0, so it looks safe — our inference, not a vendor statement
1.1.3 ≤ v < 1.6.221.7.0-beta.0 ≤ v < 1.7.0-beta.101.1.31.7.0-beta.0
Vendor states this is fixed in 1.6.22 (unaffected)
Vendor states this is fixed in 1.7.0-beta.10 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.3HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
LOW
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-287

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card