CVE-2026-66073

RabbitMQ: Atom table exhaustion via management API node field

MEDIUM
6.5
CVSS Score
Published: September 25, 2026 at 04:06 PM UTC
Updated: October 8, 2026 at 03:29 PM UTC
2 products affected across 2 vendorsRabbitmq ServerRabbitmq Server

Using rabbitmq-server by rabbitmq?

Get instant alerts when new vulnerabilities affect rabbitmq-server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.15 and 4.0.20 and 4.1.11 and 4.2.6, Atom table exhaustion via management API node field. pUT /api/queues/:vhost/:name (and the exchanges and bindings endpoints) accepts a node JSON field. The value goes through rabbitnodes:make → listtoatom with no cluster membership check first. Each unique value permanently leaks one atom. A March 2026 refactoring (ea61ce2563) introduced safe helpers in rabbitmgmtnodes.erl (parsenodename, safeatom, and requirenodename, using binarytoexistingatom) and fixed several callers (QQ replica ops, wmauthattempts, wmnodememoryets, getsortreverse, and rabbitfederationmgmt), but getnode/1 in rabbitmgmtutil.erl:880-885, the primary vector used by directrequest/6, was not Roughly 900K requests crash the VM via systemlimit, and all tenants lose Any user with the management tag and one vhost, the lowest privilege This issue is fixed in versions 3.13.15 and 4.0.20 and 4.1.11 and 4.2.6.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.13.0 ≤ v < 3.13.154.0.0 ≤ v < 4.0.204.1.0 ≤ v < 4.1.114.2.0 ≤ v < 4.2.6*
Affected range stops below 3.13.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.13.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.6, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card