CVE-2026-65948

Apache Ranger: UnixAuth lacks brute-force protection

HIGH
7.3
CVSS Score
Published: August 10, 2026 at 10:20 AM UTC
Updated: October 24, 2026 at 04:10 PM UTC
1 product affected across 1 vendorRanger

Using Apache Ranger by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Ranger - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.3
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

UnixAuth lacks brute-force protection in Apache Ranger versions <= 2.8.0.  Note:  UnixAuth is NOT a recommended option for production deployments.  Users are recommended to upgrade to version 2.9.0, which fixes this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.9.0
Affected range stops below 2.9.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

Vendor AdvisoryMailing List
Source: cverecord
https://lists.apache.org/thread/cx53rbkxkn5hbvzv8ohwvndzrxhc06qf
Mailing ListThird Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
http://www.openwall.com/lists/oss-security/2026/08/09/11

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.3HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-307

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card