CVE-2026-65897

Grav API Plugin 1.0.9 Privilege Escalation via Invitations groups

HIGH
8.8
CVSS Score
Published: July 23, 2026 at 11:42 AM UTC
Updated: October 24, 2026 at 01:10 PM UTC
1 product affected across 1 vendorGrav

Using grav by getgrav?

Get instant alerts when new vulnerabilities affect grav - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.5%
SSVC
PoC

Description

Grav API Plugin versions before 1.0.10 fail to validate the groups field in InvitationsController::create(), allowing authenticated api.users.write callers to assign invited accounts to groups that grant api.super permissions. Attackers can create invitation records with elevated group membership, and when accepted, the new account gains full super-admin API access without the inviter holding those permissions.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

90%
0 ≤ v < 1.0.100
Vendor states this is fixed in 1.0.10 (unaffected)

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-269

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card