CVE-2026-62388

NLTK before 3.10.0 Insecure Default Configuration in pathsec.py

HIGH
7.5
CVSS Score
Published: August 22, 2026 at 02:12 PM UTC
Updated: October 14, 2026 at 01:10 PM UTC
1 product affected across 1 vendorNltk

Using nltk by nltk?

Get instant alerts when new vulnerabilities affect nltk - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.5%
SSVC
PoC

Description

NLTK versions before 3.10.0 default to ENFORCE=False in pathsec.py, causing all security validation functions to emit warnings instead of raising exceptions. Attackers can bypass path traversal and pickle deserialization protections by exploiting the disabled security controls that are only active when manually enabled.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.10.0
Vendor states this is fixed in 3.10.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-1188

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card