CVE-2026-61487

Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authorization bypass via temporary composite destinations

MEDIUM
6.5
CVSS Score
Published: July 28, 2026 at 01:32 PM UTC
Updated: August 5, 2026 at 07:04 PM UTC
3 products affected across 1 vendorActiveMQActiveMQ AllApache ActiveMQ Broker

Using Apache ActiveMQ Broker by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache ActiveMQ Broker - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Improper Authorization vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. An authenticated low-privilege user can bypass a per-destination write ACL by sending to an ActiveMQ temporary composite destination whose physical name is a comma-separated composite of real queues. This allows publishing messages to any of the destinations in the list without proper write ACL permissions because the authorization check is bypassed due to the composite destination being marked as temporary. This issue affects Apache ActiveMQ Broker: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8 or 6.3.0, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.19.96.0.0 ≤ v < 6.2.86.0.0
Affected range stops below 5.19.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.8, so it looks safe — our inference, not a vendor statement
v < 5.19.96.0.0 ≤ v < 6.2.86.0.0
Affected range stops below 5.19.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.8, so it looks safe — our inference, not a vendor statement
v < 5.19.96.0.0 ≤ v < 6.2.86.0.0
Affected range stops below 5.19.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

Vendor AdvisoryMailing List
Source: cverecord
https://lists.apache.org/thread/6rwn6cq65dy4lhmsmjf2bxnhbmhkcswz
Mailing ListThird Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
http://www.openwall.com/lists/oss-security/2026/07/27/8

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-285

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card