CVE-2026-59932

PhpSpreadsheet: Gnumeric reader unbounded gzip expansion causes memory exhaustion

HIGH
7.5
CVSS Score
Published: July 28, 2026 at 05:59 PM UTC
Updated: October 23, 2026 at 11:10 PM UTC
1 product affected across 1 vendorPhpSpreadsheet

Using PhpSpreadsheet by PHPOffice?

Get instant alerts when new vulnerabilities affect PhpSpreadsheet - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.5%
SSVC
PoC

Description

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. In versions 4.0.0 through 5.8.0, 3.3.0 through 3.10.6, 2.2.0 through 2.4.6, 2.0.0 through 2.1.17, and all releases up to and including 1.30.5, the Gnumeric reader reads attacker-supplied .gnumeric files into memory and, when the file starts with gzip magic bytes, calls gzdecode() on the full compressed contents without enforcing a decompressed-size limit. A very small compressed .gnumeric file can expand to data larger than the PHP memory limit and crash the process during Gnumeric::canRead() before the file is rejected or fully parsed. This is reachable through normal file-type detection and Gnumeric loading paths, so applications that accept attacker-controlled spreadsheet uploads can suffer denial of service. This issue has been fixed in versions 5.8.1, 3.10.7, 2.4.7, 2.1.18 and 1.30.6.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.30.6>= 2.0.0, < 2.1.18>= 2.2.0, < 2.4.7>= 3.3.0, < 3.10.7>= 4.0.0, < 5.8.1
Affected range stops below 1.30.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.4.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.10.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.8.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCPoCAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-400CWE-409

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card