CVE-2026-59931

PhpSpreadsheet: SSRF bypass via HTTP redirect in WEBSERVICE() domain whitelist

HIGH
7.7
CVSS Score
Published: July 28, 2026 at 05:27 PM UTC
Updated: October 23, 2026 at 11:10 PM UTC
1 product affected across 1 vendorPhpSpreadsheet

Using PhpSpreadsheet by PHPOffice?

Get instant alerts when new vulnerabilities affect PhpSpreadsheet - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.7
Exploit prediction
EPSS 0.5%
SSVC
PoC

Description

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. In versions 4.0.0 through 5.8.0, 3.3.0 through 3.10.6, 2.2.0 through 2.4.6, 2.0.0 through 2.1.17, and all releases up to and including 1.30.5, the WEBSERVICE() domain whitelist can be bypassed via an HTTP redirect (SSRF). In Calculation/Web/Service.php, the webService() method validates a URL's host against the whitelist set via Spreadsheet::setDomainWhiteList(), then fetches content with file_get_contents($url, false, $ctx); because PHP's HTTP stream wrapper follows 301/302 redirects automatically (up to 20 hops) and the redirect target is never re-validated, an attacker who can trigger a redirect from a whitelisted domain can reach arbitrary URLs, including internal addresses. An attacker able to upload XLSX files to an application that uses setDomainWhiteList() and getCalculatedValue() can achieve a full-read SSRF, returning up to 32,767 bytes of the response body as a cell's calculated value, which enables exfiltration of cloud metadata (AWS/GCP/Azure credentials via http://169.254.169.254/), access to internal-only services, and internal port scanning (the port is not validated). This issue has been fixed in versions 5.8.1, 3.10.7, 2.4.7, 2.1.18, and 1.30.6.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.30.6>= 2.0.0, < 2.1.18>= 2.2.0, < 2.4.7>= 3.3.0, < 3.10.7>= 4.0.0, < 5.8.1
Affected range stops below 1.30.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.4.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.10.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.8.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.7HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card