CVE-2026-59822

LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback

HIGH
8.2
CVSS Score
Published: July 8, 2026 at 07:32 PM UTC
Updated: October 25, 2026 at 05:10 PM UTC
2 products affected across 2 vendorsLiteLLMLiteLLM

Using litellm by BerriAI?

Get instant alerts when new vulnerabilities affect litellm - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.2
Exploitation
CISA KEV
Exploit prediction
EPSS 0.8%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score0.8%

EPSS (Exploit Prediction Scoring System) estimates a 0.8% chance this CVE is exploited in the wild within the next 30 days — higher than 57% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

BerriAI LiteLLM contains an improper authentication vulnerability in the MCP Streamable HTTP endpoint that could allow an unauthenticated attacker to establish an authenticated MCP session using an arbitrary Bearer token.

Required Action
Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
Ransomware Use
Unknown
Added to KEV
Sep 2, 2026
Remediation Due
Sep 16, 2026
40 days overdue

Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, LiteLLM's MCP Streamable HTTP endpoint allowed an unauthenticated attacker to use a fabricated Authorization header to trigger an OAuth2 passthrough fallback path that replaced failed LiteLLM key validation with an empty UserAPIKeyAuth() object, allowing requests to reach MCP tooling without a valid LiteLLM key. This issue is fixed in version 1.84.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.84.0
Affected range stops below 1.84.0, so it looks safe — our inference, not a vendor statement
v < 1.84.0
Affected range stops below 1.84.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (6)

x_refsource_CONFIRMMitigationPatchVendor Advisory
Source: cverecord
https://github.com/BerriAI/litellm/security/advisories/GHSA-7488-6r32-c95q
x_refsource_MISCIssue TrackingPatch
Source: cverecord
https://github.com/BerriAI/litellm/pull/26463
x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/BerriAI/litellm/releases/tag/v1.84.0
Third Party Advisory
Source: 134c704f-9b21-4f2e-91b3-4a467353bcc0
https://www.wiz.io/blog/ai-infrastructure-honeypot
US Government Resource
Source: 134c704f-9b21-4f2e-91b3-4a467353bcc0
https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-59822

SSVC — Action Prioritization

SSVCActiveAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-287CWE-306

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card