CVE-2026-5921

Server-Side Request Forgery in GitHub Enterprise Server allowed extraction of sensitive environment variables via timing side-channel attack

HIGH
8.9
CVSS Score
Published: April 21, 2026 at 10:11 PM UTC
Updated: October 26, 2026 at 10:10 PM UTC
1 product affected across 1 vendorGitHub Enterprise Server

Using Enterprise Server by GitHub?

Get instant alerts when new vulnerabilities affect Enterprise Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.9
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

A server-side request forgery (SSRF) vulnerability was identified in GitHub Enterprise Server that allowed an attacker to extract sensitive environment variables from the instance through a timing side-channel attack against the notebook rendering service. When private mode was disabled, the notebook viewer followed HTTP redirects without revalidating the destination host, enabling an unauthenticated SSRF to internal services. By chaining this with regex filter queries against an internal API and measuring response time differences, an attacker could infer secret values character by character. Exploitation required that private mode be disabled and that the attacker be able to chain the instance's open redirect endpoint through an external redirect to reach internal services. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.14.26, 3.15.21, 3.16.17, 3.17.14, 3.18.8, 3.19.5, and 3.20.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.14.263.15.0 ≤ v < 3.15.213.16.0 ≤ v < 3.16.173.17.0 ≤ v < 3.17.143.18.0 ≤ v < 3.18.83.19.0 ≤ v < 3.19.53.14.03.15.03.16.03.17.03.18.03.19.03.20.0
Affected range stops below 3.14.26, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.15.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.16.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.17.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.18.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.19.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.20.1, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.9HIGHGitHub_P
Vector?

Quick Info

StatusANALYZED
CWE
CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card