CVE-2026-59153

Anki's local HTTP server does not sufficiently validate requests

LOW
2.1
CVSS Score
Published: July 7, 2026 at 09:11 PM UTC
Updated: October 25, 2026 at 08:10 PM UTC
1 product affected across 1 vendorAnki

Using anki by ankitects?

Get instant alerts when new vulnerabilities affect anki - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW2.1
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, Anki launches a local HTTP server to serve media files and web pages for parts of its interface, but requests from other origins were not sufficiently blocked. A malicious website could potentially trigger side-effecting requests to the local server, with severity varying by browser depending on Private Network Access protections. This issue is fixed in version 25.09.3.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 25.09.3
Affected range stops below 25.09.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

2.1LOWGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-346

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card