CVE-2026-57480

Parse Server: Denial of service via exponential-time processing of deeply nested query operators

HIGH
8.7
CVSS Score
Published: July 8, 2026 at 08:53 PM UTC
Updated: October 25, 2026 at 05:10 PM UTC
1 product affected across 1 vendorParse Server

Using parse-server by parse-community?

Get instant alerts when new vulnerabilities affect parse-server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.7
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.12 and 8.6.82, deeply nested $or, $and, and $nor query condition operators in the REST API or LiveQuery query handling could trigger exponential-time processing in the internal query-traversal helper and block the Node.js event loop. This issue is fixed in versions 9.9.1-alpha.12 and 8.6.82.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 8.6.82, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.9.1-alpha.12, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.7HIGHGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-407

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card