CVE-2026-5747

Out-of-bounds Write in Firecracker virtio-pci Transport

HIGH
7.5
CVSS Score
Published: April 7, 2026 at 11:17 PM UTC
Updated: July 24, 2026 at 09:23 AM UTC
2 products affected across 2 vendorsFirecrackerFirecracker

Using Firecracker by AWS?

Get instant alerts when new vulnerabilities affect Firecracker - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

An out-of-bounds write issue in the virtio PCI transport in Amazon Firecracker 1.13.0 through 1.14.3 and 1.15.0 on x86_64 and aarch64 might allow a local guest user with root privileges to crash the Firecracker VMM process or potentially execute arbitrary code on the host via modification of virtio queue configuration registers after device activation. Achieving code execution on the host requires additional preconditions, such as the use of a custom guest kernel or specific snapshot configurations. To remediate this, users should upgrade to Firecracker 1.14.4 or 1.15.1 and later.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.13.0 ≤ v ≤ 1.14.31.15.01.15.0 dev
1.13.0 ≤ v ≤ 1.14.31.13.01.15.0
Vendor states this is fixed in 1.14.4 (unaffected)
Vendor states this is fixed in 1.15.1 (unaffected)

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHAMZN
Attack Vector
LOCAL
Complexity
HIGH
Privileges
HIGH
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-787CWE-369

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card