CVE-2026-57185

Asterisk: Buffer over-read in Asterisk PJSIP MWI body parser

MEDIUM
6.5
CVSS Score
Published: October 27, 2026 at 04:40 PM UTC
Updated: October 28, 2026 at 02:18 PM UTC
2 products affected across 1 vendorAsteriskCertified Asterisk

Using asterisk by asterisk?

Get instant alerts when new vulnerabilities affect asterisk - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.5%

Description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may crash Asterisk through a buffer over-read in the `PJSIP MWI body parser` by sending a carefully crafted `SIP NOTIFY` request. The attacker must pass SIP authentication using either a username/password or `source IP address matching`. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 20.20.121.0.0-pre1 ≤ v < 21.12.322.0.0-pre1 ≤ v < 22.10.123.0.0-pre1 ≤ v < 23.4.121.0.0-pre122.0.0-pre123.0.0-pre1
v < 20.7-cert1122.8-cert1-pre1 ≤ v < 22.8-cert322.8-cert1-pre1

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

CVSS

6.5MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-126CWE-170

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card