CVE-2026-56822

Netty: TOCTOU in OcspServerCertificateValidator

HIGH
7.4
CVSS Score
Published: July 28, 2026 at 11:17 PM UTC
Updated: August 7, 2026 at 03:05 PM UTC
1 product affected across 1 vendorNetty

Using netty by netty?

Get instant alerts when new vulnerabilities affect netty - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.4
Exploit prediction
EPSS 0.2%
SSVC
PoC

Description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the OcspServerCertificateValidator forwards the SslHandshakeCompletionEvent before the asynchronous OCSP validation completes. This allows the client's downstream handlers to send sensitive application data (e.g., HTTP requests) to a revoked server before the channel is closed by the OCSP check. n io.netty.handler.ssl.ocsp.OcspServerCertificateValidator#userEventTriggered, when an SslHandshakeCompletionEvent is received, the validator immediately calls ctx.fireUserEventTriggered(evt). It then initiates an asynchronous OCSP query using OcspClient.query. Because the handshake completion event is forwarded immediately, downstream handlers in the client's pipeline are notified that the TLS handshake is successful. They may then begin reading and processing incoming application data or sending outgoing data. If the OCSP response later indicates the server's certificate is REVOKED, the validator closes the channel, but by this time, the client may have already leaked sensitive data to a revoked server or processed malicious responses from it. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.1.136v < 4.1.136.Finalv < 4.2.16.Final4.2.0 ≤ v < 4.2.16
Affected range stops below 4.1.136, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.136.Final, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.16.Final, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

x_refsource_CONFIRMVendor Advisory
Source: cverecord
https://github.com/netty/netty/security/advisories/GHSA-wc96-39fc-566f

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.4HIGHGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-367

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card