CVE-2026-56821

Netty: Out-of-date OCSP Responses Accepted by OcspServerCertificateValidator

HIGH
7.4
CVSS Score
Published: July 28, 2026 at 11:07 PM UTC
Updated: August 7, 2026 at 03:05 PM UTC
1 product affected across 1 vendorNetty

Using netty by netty?

Get instant alerts when new vulnerabilities affect netty - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.4
Exploit prediction
EPSS 0.2%
SSVC
PoC

Description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the OcspServerCertificateValidator flags an out-of-date OCSP response but does not stop processing it, so an expired GOOD response is still reported as VALID, letting an on-path attacker replay a stale GOOD response to bypass revocation of a since-revoked certificate. Exploitation can lead to certificate revocation bypass via replay of an expired OCSP response. Any application using OcspServerCertificateValidator is affected; a revoked certificate can be accepted. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.1.136v < 4.1.136.Finalv < 4.2.16.Final4.2.0 ≤ v < 4.2.16
Affected range stops below 4.1.136, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.136.Final, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.16.Final, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

x_refsource_CONFIRMExploitVendor Advisory
Source: cverecord
https://github.com/netty/netty/security/advisories/GHSA-g7hg-vrcf-mvmr

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.4HIGHGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-299

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card