CVE-2026-56340

vLLM - Denial of Service via Unvalidated Multimodal Embeddings

HIGH
7.5
CVSS Score
Published: June 20, 2026 at 06:27 PM UTC
Updated: October 23, 2026 at 11:10 PM UTC
2 products affected across 2 vendorsvLLMAI Inference Server

Using vLLM by vLLM?

Get instant alerts when new vulnerabilities affect vLLM - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

vLLM versions >= 0.10.2 and < 0.13.0 are missing sparse tensor validation in multimodal embeddings processing. Because PyTorch disables sparse tensor invariant checks by default, an attacker can submit crafted embedding requests with malformed (negative or out-of-bounds) tensor indices, when the prompt-embeds feature is enabled, to trigger crashes or resource exhaustion (denial of service), with potential for out-of-bounds/write-what-where memory corruption. This continues CVE-2025-62164, whose prior fix only disabled the feature by default rather than addressing the root cause.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0.10.2 ≤ v < 0.13.00.10.2
Vendor states this is fixed in 0.13.0 (unaffected)
All versions

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-20NVD-CWE-noinfoCWE-787

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card