CVE-2026-55856

MariaDB Connector/J: Cleartext password disclosure to a MITM on the initial-handshake

MEDIUM
5.9
CVSS Score
Published: August 28, 2026 at 10:41 PM UTC
Updated: September 8, 2026 at 09:19 PM UTC
1 product affected across 1 vendorConnector/J

Using mariadb-connector-j by mariadb-corporation?

Get instant alerts when new vulnerabilities affect mariadb-connector-j - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.9
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

MariaDB Connector/J is used to connect applications developed in Java to MariaDB and MySQL databases. Prior to 2.7.14, 3.3.5, 3.4.3, and 3.5.9, when a Java application connects with sslMode=verify-full or sslMode=verify-ca, supplies a password, and does not configure serverSslCert or trustStore, Connector/J can accept an untrusted self-signed certificate through the fallbackToSystemTrustStore=true ephemeral trust manager and record its certFingerprint for later identity binding. The OK-packet and authentication-switch paths enforce the certificate fingerprint, but the initial-handshake path does not. HandshakeResponse.encode() can therefore build and send a mysql_clear_password response before checking certFingerprint != null && !isMitMProof(), sslMode, or whether the authentication plugin is resistant to a man-in-the-middle, and the initial path also bypasses restrictedAuth. An active man-in-the-middle or hostile server can present a self-signed certificate, claim to be MariaDB, select mysql_clear_password as the initial authentication plugin, and receive the full database password before the connection is rejected. This issue is fixed in versions 2.7.14, 3.3.5, 3.4.3, and 3.5.9.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.7.14v < 3.3.5v < 3.4.3v < 3.5.9
Affected range stops below 2.7.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.3.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.4.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.5.9, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.9MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-522

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card