CVE-2026-54891

Plaintext APPLICATION_DATA injected during TLS handshake delivered to client application post-handshake in ssl

LOW
3.7
CVSS Score
Published: July 2, 2026 at 04:06 PM UTC
Updated: October 25, 2026 at 09:10 PM UTC
2 products affected across 1 vendorErlang /otpErlang /ssl

Using OTP by Erlang?

Get instant alerts when new vulnerabilities affect OTP - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.7
Exploit prediction
EPSS 0.1%
SSVC
No known exploit

Description

Improper Enforcement of Message Integrity During Transmission in a Communication Channel vulnerability in Erlang/OTP ssl (tls_gen_connection module) allows a network-positioned attacker to inject unauthenticated plaintext that the TLS client application later treats as authenticated server data. The function tls_gen_connection:handle_protocol_record/3 rejects APPLICATION_DATA records that arrive in pre-handshake states when the TLS endpoint acts as a server, but does not apply the same check when the endpoint acts as a client. A network-positioned attacker can send plaintext APPLICATION_DATA records to the client during the handshake. The records are buffered and, once the handshake completes successfully, delivered to the application as if they were authenticated post-handshake data. The attacker cannot observe the client's response or steer the connection, so the impact is limited to blind injection of unauthenticated bytes. The injection window is wider for TLS versions prior to TLS 1.3 than for TLS 1.3. This vulnerability is associated with program file lib/ssl/src/tls_gen_connection.erl. This issue affects OTP from OTP 17.0 before 29.0.3, 28.5.0.3 and 27.3.4.14 corresponding to ssl from 5.3.4 before 11.7.3, 11.6.0.3 and 11.2.12.10. TLS 1.3 is affected starting with OTP 22.0, when TLS 1.3 support was added.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

17.0 ≤ v < 27.3.4.1428.0 ≤ v < 28.5.0.329.0 ≤ v < 29.0.311.311.717.028.029.05.3.484adefa331c4159d432d22840663c38f155cd4c1
Vendor states this is fixed in 07d2d0e93f6aaf7652a81e8df075fc1728da5e96 (fixed)
Affected range stops below 11.2.12.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.6.0.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.7.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 27.3.4.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 28.5.0.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 29.0.3, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 17.0 (unknown)
Vendor states this is fixed in 5.3.4 (unknown)
11.3 ≤ v < 11.6.0.311.7 ≤ v < 11.7.35.3.4 ≤ v < 11.2.12.10
Affected range stops below 11.2.12.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.6.0.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.7.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (5)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-924

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card