CVE-2026-53488

containerd CRI plugin: — image-config `LABEL` flows to restart-monitor `binary://` logger: host-root command execution from an image pull

HIGH
8.8
CVSS Score
Published: July 1, 2026 at 12:11 AM UTC
Updated: July 3, 2026 at 04:17 AM UTC
2 products affected across 2 vendorsContainerdContainerd

Using containerd by containerd?

Get instant alerts when new vulnerabilities affect containerd - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

containerd is an open-source container runtime. In versions prior to 1.7.33, 2.3.2, 2.2.5, 2.1.9, and 2.0.10 the CRI plugin propagates labels from an image config (LABEL instruction in Dockerfile) to a container without validation. This may result in executing an arbitrary command on the host, via a plugin that consumes container labels for some operations. This issue has been fixed in versions 1.7.33, 2.3.2, 2.2.5, 2.1.9, and 2.0.10.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.7.0 ≤ v < 1.7.332.0.0 ≤ v < 2.0.102.1.0 ≤ v < 2.1.92.2.0 ≤ v < 2.2.52.3.0 ≤ v < 2.3.2
Affected range stops below 1.7.33, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.2.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.3.2, so it looks safe — our inference, not a vendor statement
v < 1.7.33v < 2.0.10v < 2.1.9v < 2.2.5v < 2.3.2
Affected range stops below 1.7.33, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.2.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.3.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

x_refsource_CONFIRMMitigationVendor Advisory
Source: cverecord
https://github.com/containerd/containerd/security/advisories/GHSA-xhf5-7wjv-pqxp

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-20

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card