CVE-2026-53317

wifi: mt76: mt7921: Place upper limit on station AID

MEDIUM
5.5
CVSS Score
Published: June 26, 2026 at 07:41 PM UTC
Updated: October 21, 2026 at 01:19 PM UTC
1 product affected across 1 vendorLinux Kernel

Using Linux by Linux?

Get instant alerts when new vulnerabilities affect Linux - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.2%

Description

In the Linux kernel, the following vulnerability has been resolved: wifi: mt76: mt7921: Place upper limit on station AID Any station configured with an AID over 20 causes a firmware crash. This situation occurred in our testing using an AP interface on 7922 hardware, with a modified hostapd, sourced from Mediatek's OpenWRT feeds. In stock hostapd, station AIDs begin counting at 1, and this configuration is prevented with an upper limit on associated stations. However, the modified hostapd began allocation at 65, which caused the firmware to crash. This fix does not allow these AIDs to work, but will prevent the firmware crash. This crash was only seen on IFTYPE_AP interfaces, and the fix does not appear to have an effect on IFTYPE_STATION behavior.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

5.12 ≤ v < 6.12.916.13 ≤ v < 6.18.336.19 ≤ v < 7.0.105.125c14a5f944b91371961548b1907802f74a4d2e5c
Vendor states this is fixed in 1a4b802afe15c5b33b2dcb37a594aba2fa215d52 (fixed)
Vendor states this is fixed in 35835ff71e6e618155578b8e3905597edd5f601c (fixed)
Vendor states this is fixed in 4d0bf21e3e20619d51d06c0c36207aabab8b712c (fixed)
Vendor states this is fixed in 6dbe70f9ef14d8ac1c24bf19fd9510978a3ab952 (fixed)
Vendor states this is fixed in 5.12 (unaffected)
Vendor states this is fixed in 6.12.91 (unaffected)
Vendor states this is fixed in 6.18.33 (unaffected)
Vendor states this is fixed in 6.6.160 (unaffected)
Vendor states this is fixed in 7.0.10 (unaffected)
Vendor states this is fixed in 7.1 (unaffected)

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card