CVE-2026-53107

wifi: libertas: don't kill URBs in interrupt context

MEDIUM
5.5
CVSS Score
Published: June 24, 2026 at 04:30 PM UTC
Updated: July 23, 2026 at 09:41 PM UTC
1 product affected across 1 vendorLinux Kernel

Using Linux by Linux?

Get instant alerts when new vulnerabilities affect Linux - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.2%

Description

In the Linux kernel, the following vulnerability has been resolved: wifi: libertas: don't kill URBs in interrupt context Serialization for the TX path was enforced by calling usb_kill_urb()/usb_kill_anchored_urbs(), to prevent transmission before a previous URB was completed. usb_tx_block() can be called from interrupt context (e.g. in the HCD giveback path), so we can't always use it to kill in-flight URBs. Prevent sleeping during interrupt context by checking the tx_submitted anchor for existing URBs. We now return -EBUSY, to indicate there's a pending request.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≥ 5.10.252v ≥ 5.15.202v ≥ 6.1.165v ≥ 6.12.75v ≥ 6.19.6v ≥ 6.6.1285.10.252 ≤ v < 5.115.15.202 ≤ v < 5.166.1.165 ≤ v < 6.26.12.75 ≤ v < 6.136.18.16 ≤ v < 6.18.336.19.6 ≤ v < 6.206.19.6 ≤ v < 7.0.106.6.128 ≤ v < 6.77.0 ≤ v < 7.0.107.0 ≤ v < 7.12902a9b4415a6bafc9b1e5dd360f065d757a0bb73308c7504e093b22e91a4468470309cee2e26b83498525d8358d6d20918787e59736d5b6a021e9fd5.10.2525.15.2025bfb25495e391a1be0db94b15715174fa06b93a16.1.1656.12.756.18.166.19.66.6.1287.0948a39c95d0f8d73722910f8cdb7b6e3e9206232b82073564373e68c6ae3a96039fae14cd002a496d66676e6ca96bf8680f869a9bd6573b26c634622fc188b44547dea4e7350833171982a6312befde9
Vendor states this is fixed in 00c0317cebf44151df18fb647781f315268cdd98 (fixed)
Vendor states this is fixed in 4f273d3f98ebc60c30bbfb3ed4a7f0477d3eaed2 (fixed)
Vendor states this is fixed in 7c5c2b661bdb78c1472b8833265c9ed1ee880039 (fixed)
Affected range stops below 5.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.13, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.18.33 (unaffected)
Affected range stops below 6.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.7, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 7.0 (unaffected)
Vendor states this is fixed in 7.0.10 (unaffected)
Vendor states this is fixed in 7.1 (unaffected)

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card