CVE-2026-5138

Foreman: foreman: information disclosure via improper validation of nested request parameters

MEDIUM
4.3
CVSS Score
Published: July 1, 2026 at 02:08 PM UTC
Updated: July 9, 2026 at 02:55 AM UTC
3 products affected across 2 vendorsSatelliteForemanEnterprise Linux

Using Red Hat Satellite 6 by Red Hat?

Get instant alerts when new vulnerabilities affect Red Hat Satellite 6 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

A flaw was found in Foreman. An authenticated user with host-edit permissions could exploit a cross-tenant information disclosure vulnerability. This flaw occurs because the taxonomy_scope controller method does not properly validate organization and location IDs from nested request parameters, bypassing existing authorization checks. This allows the user to leak sensitive infrastructure metadata, including subnet topology, IP ranges, gateways, DNS servers, and VLAN IDs, from organizations and locations they are not authorized to access.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

6.16 ≤ v < 6.16.106.17 ≤ v < 6.17.96.18 ≤ v < 6.18.76.19 ≤ v < 6.19.2
Vendor states this is fixed in 0:3.12.0.17-1.el8sat (unaffected)
Vendor states this is fixed in 0:3.12.0.17-1.el9sat (unaffected)
Vendor states this is fixed in 0:3.14.0.17-1.el9sat (unaffected)
Vendor states this is fixed in 0:3.16.0.17-1.el9sat (unaffected)
Vendor states this is fixed in 0:3.18.0.7-1.el9sat (unaffected)
Affected range stops below 6.16.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.17.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.18.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.19.2, so it looks safe — our inference, not a vendor statement
redhat-enterprise-linux (environment)
v < 3.18.23.19.0 ≤ v < 3.19.1
Affected range stops below 3.18.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.19.1, so it looks safe — our inference, not a vendor statement
All versions

References (6)

VDB Entryx_refsource_REDHATVendor Advisory
Source: cverecord
https://access.redhat.com/security/cve/CVE-2026-5138
Issue Trackingx_refsource_REDHATVendor Advisory
Source: cverecord
https://bugzilla.redhat.com/show_bug.cgi?id=2452971
Vendor Advisoryx_refsource_REDHAT
Source: cverecord
https://access.redhat.com/errata/RHSA-2026:34367
Vendor Advisoryx_refsource_REDHAT
Source: cverecord
https://access.redhat.com/errata/RHSA-2026:34368
Vendor Advisoryx_refsource_REDHAT
Source: cverecord
https://access.redhat.com/errata/RHSA-2026:34365
Vendor Advisoryx_refsource_REDHAT
Source: cverecord
https://access.redhat.com/errata/RHSA-2026:34366

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.3MEDIUMredhat
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-639

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card