CVE-2026-50750

Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All: Pre-authentication OpenWire DoS following fix for CVE-2026-49270

HIGH
7.5
CVSS Score
Published: June 30, 2026 at 09:51 AM UTC
Updated: July 2, 2026 at 06:58 PM UTC
3 products affected across 1 vendorActiveMQApache ActiveMQ BrokerActiveMQ All

Using Apache ActiveMQ Broker by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache ActiveMQ Broker - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Following the fix for CVE-2026-49270 an unauthenticated attacker can now cause broker OOM by sending an repeated BrokerInfo commands without sending a ConnectionInfo, until the broker will crash with OOM. This issue affects Apache ActiveMQ Broker: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ All: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7. Users are recommended to upgrade to version 6.2.7, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

5.19.7 ≤ v < 5.19.86.2.6 ≤ v < 6.2.75.19.76.2.6
Affected range stops below 5.19.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.7, so it looks safe — our inference, not a vendor statement
5.19.7 ≤ v < 5.19.86.2.6 ≤ v < 6.2.75.19.76.2.6
Affected range stops below 5.19.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.7, so it looks safe — our inference, not a vendor statement
5.19.7 ≤ v < 5.19.86.2.6 ≤ v < 6.2.75.19.76.2.6
Affected range stops below 5.19.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

Vendor AdvisoryMailing List
Source: cverecord
https://lists.apache.org/thread/nhkmbdym61yp6wwy0dny8w1p46sm87kr

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card