CVE-2026-50555

Angular: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in @angular/platform-server

MEDIUM
6.1
CVSS Score
Published: June 22, 2026 at 03:37 PM UTC
Updated: July 9, 2026 at 03:41 PM UTC
1 product affected across 1 vendor@angular

Using angular by angular?

Get instant alerts when new vulnerabilities affect angular - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25, a Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of raw-text elements (such as <script>, <style>, and <iframe>). domino supports escaping raw-text elements during serialization to prevent closing-tag breakout. However, a Unicode index alignment bug existed in this escaping logic. In JavaScript, string lengths and character indices are calculated based on UTF-16 code units (where astral characters—such as emojis—occupy 2 code units / 4 bytes). If the bound dynamic text contained astral Unicode characters before the closing tag (e.g. </script>, </style>, or </iframe>), the index offset calculation in domino's replacement logic shifted. This misalignment caused domino to fail to replace or escape the closing tag, leaving it raw and unescaped in the output HTML. An attacker who controls the dynamic text can supply a payload containing both an astral Unicode character and a closing tag (e.g., 😀</iframe><script>alert(1)</script>). When serialized on the server during SSR, the browser parses the unescaped closing tag, exits the raw-text context early, and executes the subsequent <script> block, leading to same-origin Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 18.2.14v < 19.2.25v < 20.3.24v < 21.2.16v < 22.0.0-rc.219.0.0 ≤ v < 19.2.2520.0.0 ≤ v < 20.3.2421.0.0 ≤ v < 21.2.622.0.0 next022.0.0 next122.0.0 next1022.0.0 next1122.0.0 next1222.0.0 next222.0.0 next322.0.0 next422.0.0 next522.0.0 next622.0.0 next722.0.0 next822.0.0 next922.0.0 rc022.0.0 rc1
Affected range stops below 19.2.25, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3.24, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.0.0-rc.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (2)

x_refsource_CONFIRMThird Party Advisory
Source: cverecord
https://github.com/angular/angular/security/advisories/GHSA-hqr9-c56f-3x7f
x_refsource_MISCIssue TrackingPatch
Source: cverecord
https://github.com/angular/domino/pull/29

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card