CVE-2026-50169

Angular Service Worker Policy-Bypass & Credential-Stripping Vulnerabilities

MEDIUM
6.1
CVSS Score
Published: June 22, 2026 at 03:41 PM UTC
Updated: July 9, 2026 at 03:31 PM UTC
1 product affected across 1 vendor@angular

Using angular by angular?

Get instant alerts when new vulnerabilities affect angular - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15 20.3.22, and 19.2.23, an issue in the @angular/service-worker package compromises the integrity of request-policy enforcement during request reconstruction. When the Angular Service Worker intercepts network requests for matched assets, it reconstructs a new Request object using an internal helper function. During this reconstruction process, the helper function strips the strict, client-defined request redirect policy configuration (such as redirect: 'error'), falling back to the browser's default 'follow' strategy. If the target web application makes client-side requests with a strict policy (e.g., expecting a network error instead of automatically following redirects), the service worker will bypass this instruction and automatically follow HTTP 3xx redirects to other destinations. This acts as an unintended proxy/intermediary ("Confused Deputy") and can result in cookie/credential exposure or same-origin session-restricted data leakage if public dynamic routes redirect to sensitive routes. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 18.2.14v < 19.2.23v < 20.3.22v < 21.2.15v < 22.0.0-rc.219.0.0 ≤ v < 19.2.2320.0.0 ≤ v < 20.3.2221.0.0 ≤ v < 21.2.1522.0.0 next022.0.0 next122.0.0 next1022.0.0 next1122.0.0 next1222.0.0 next222.0.0 next322.0.0 next422.0.0 next522.0.0 next622.0.0 next722.0.0 next822.0.0 next922.0.0 rc022.0.0 rc1
Affected range stops below 19.2.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.0.0-rc.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

x_refsource_CONFIRMThird Party Advisory
Source: cverecord
https://github.com/angular/angular/security/advisories/GHSA-gv2q-mqqv-365m
x_refsource_MISCIssue TrackingPatch
Source: cverecord
https://github.com/angular/angular/pull/67494

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-200CWE-441CWE-524

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card