CVE-2026-50147

Metabase: Arbitrary File Read via MySQL Connection Property Injection

HIGH
7.6
CVSS Score
Published: July 15, 2026 at 03:21 PM UTC
Updated: July 30, 2026 at 06:22 PM UTC
1 product affected across 1 vendorMetabase

Using metabase by metabase?

Get instant alerts when new vulnerabilities affect metabase - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.6
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Metabase is an open-source business intelligence and embedded analytics tool. From 1.57.0 until 1.57.19.1, 1.58.14.1, 1.59.10, and 1.60.4, an attacker who can configure a Metabase database connection can read arbitrary files from the Metabase server's filesystem by adding unsafe JDBC parameters to a MySQL or MariaDB connection, causing the driver to read files from the Metabase host and expose the contents through queries against the connected database or through validation error messages. This issue is fixed in versions 1.57.19.1, 1.58.14.1, 1.59.10, and 1.60.4.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.57.19.1v < 1.58.14.1v < 1.59.10v < 1.60.41.57.0 ≤ v < 1.57.19.11.58.0 ≤ v < 1.58.14.11.59.0 ≤ v < 1.59.101.60.0 ≤ v < 1.60.4
Affected range stops below 1.57.19.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.58.14.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.59.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.60.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

x_refsource_CONFIRMVendor Advisory
Source: cverecord
https://github.com/metabase/metabase/security/advisories/GHSA-mfpj-crjq-xrcp

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.6HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-88

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card