CVE-2026-49858

API Platform Core: Cross-user attribute leak in JSON:API and HAL item normalizers due to missing isCacheKeySafe gate

MEDIUM
5.9
CVSS Score
Published: July 1, 2026 at 07:24 PM UTC
Updated: July 2, 2026 at 06:58 PM UTC
3 products affected across 1 vendorCoreHALJSON:API

Using core by api-platform?

Get instant alerts when new vulnerabilities affect core - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.9
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

API Platform Core is a system to create hypermedia-driven REST and GraphQL APIs. In versions from 2.6.0 prior to 4.1.29, 4.2.26, and 4.3.12, a missing isCacheKeySafe gate in the JSON:API and HAL item normalizers causes a cross-user attribute leak. #[ApiProperty(security: ...)] is evaluated per request to decide whether a property is exposed. The componentsCache arrays in ApiPlatform\JsonApi\Serializer\ItemNormalizer and ApiPlatform\Hal\Serializer\ItemNormalizer are keyed on $context['cache_key'], which is set unconditionally before delegating to the parent normalizer. The component structure (attributes, relationships, links) computed for one request can therefore be reused for a subsequent request whose user has a different set of accessible properties. A user with lower privileges may end up seeing the structure of properties that the security predicate would otherwise have hidden for them. This issue has been fixed in versions 4.1.29, 4.2.26, and 4.3.12.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.1.29v < 4.2.25v < 4.3.8
Affected range stops below 4.1.29, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.25, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.8, so it looks safe — our inference, not a vendor statement
v < 4.1.29v < 4.2.25v < 4.3.8
Affected range stops below 4.1.29, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.25, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.8, so it looks safe — our inference, not a vendor statement
v < 4.1.29v < 4.2.25v < 4.3.8
Affected range stops below 4.1.29, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.25, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.9MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-524CWE-639

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card