CVE-2026-49270

Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All: Durable Subscription Disclosure via Crafted BrokerInfo (OpenWire)

MEDIUM
5.9
CVSS Score
Published: June 1, 2026 at 07:19 AM UTC
Updated: July 22, 2026 at 07:37 AM UTC
3 products affected across 1 vendorActiveMQApache ActiveMQ BrokerActiveMQ All

Using Apache ActiveMQ Broker by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache ActiveMQ Broker - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.9
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Brokers that are configured with a network connector with syncDurableSubs set to true, are vulnerable to an unauthenticated attacker who can receive a list of all durable topic subscriptions in the broker, including client identifiers, subscription names, topic destinations, and JMS selector expressions, by sending a BrokerInfo command. The broker incorrectly responds without first ensuring the connection is authenticated. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.19.75.14.0 ≤ v < 5.19.76.0.0 ≤ v < 6.2.65.14.06.0.0
Affected range stops below 5.19.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.6, so it looks safe — our inference, not a vendor statement
v < 5.19.75.14.0 ≤ v < 5.19.76.0.0 ≤ v < 6.2.65.14.06.0.0
Affected range stops below 5.19.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.6, so it looks safe — our inference, not a vendor statement
5.14.0 ≤ v < 5.19.76.0.0 ≤ v < 6.2.65.14.06.0.0
Affected range stops below 5.19.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.6, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

Mailing ListThird Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
http://www.openwall.com/lists/oss-security/2026/05/31/22

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.9MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-1230

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card