CVE-2026-49241

Angular: Multiple Remote Code Execution Vulnerabilities in Angular Language Service VS Code Extension

HIGH
8.8
CVSS Score
Published: June 22, 2026 at 03:16 PM UTC
Updated: June 27, 2026 at 11:41 AM UTC
2 products affected across 1 vendorAngular Language Service@angular

Using angular by angular?

Get instant alerts when new vulnerabilities affect angular - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

The Angular Language Service VS Code Extension provides a rich editing experience for Angular templates. Prior to 21.2.4, the client-side Angular Language Service VS Code extension reads the custom TypeScript SDK paths typescript.tsdk and js/ts.tsdk.path directly from workspace configurations (.vscode/settings.json) without verifying VS Code Workspace Trust state or asking for user consent (located in client/src/client.ts). The client-side extension then passes the parsed settings path as a command-line argument (--tsdk) to the background Node.js language server process. During server initialization, the background language server resolves and dynamically imports (via standard Node.js require()) the module library tsserverlibrary.js relative to the workspace-specified custom directory path. An attacker can exploit this behavior by committing a repository containing a local malicious tsserverlibrary.js script inside a custom folder, and a crafted .vscode/settings.json file pointing to that folder. When a developer opens the repository folder in VS Code, the extension automatically attempts to initialize and load the server, which dynamically resolves, loads, and executes the malicious script silently in the background. This vulnerability is fixed in 21.2.4.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 21.2.4
Affected range stops below 21.2.4, so it looks safe — our inference, not a vendor statement
v < 21.2.4
Affected range stops below 21.2.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_CONFIRMVendor Advisory
Source: cverecord
https://github.com/angular/angular/security/advisories/GHSA-ccq4-xmxr-8hcq
x_refsource_MISCIssue Tracking
Source: cverecord
https://github.com/angular/angular/pull/68857
x_refsource_MISCIssue Tracking
Source: cverecord
https://github.com/angular/angular/pull/68886

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79CWE-94CWE-427CWE-494

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card