CVE-2026-48784

Symfony: UrlGenerator Dot-Segment Encoding Skips Every Other Chained `../` or `./` → Generated URL Collapses Off-Route Under RFC 3986 Normalization

MEDIUM
6.1
CVSS Score
Published: July 14, 2026 at 07:04 PM UTC
Updated: July 15, 2026 at 03:04 PM UTC
3 products affected across 2 vendorsSymfonySymfonyRouting

Using symfony by symfony?

Get instant alerts when new vulnerabilities affect symfony - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.53, 6.4.41, 7.4.13, and 8.0.13, UrlGenerator::doGenerate() used strtr() dot-segment encoding that skipped every other chained ../ or ./ segment, allowing attacker-controlled route parameters to generate URLs that collapse to a different path under RFC 3986 normalization. This issue is fixed in versions 5.4.53, 6.4.41, 7.4.13, and 8.0.13.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.4.536.0.0 ≤ v < 6.4.417.0.0 ≤ v < 7.4.138.0.0 ≤ v < 8.0.13
Affected range stops below 5.4.53, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.41, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.4.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.13, so it looks safe — our inference, not a vendor statement
v < 5.4.53v < 6.4.41v < 7.4.13v < 8.0.13
Affected range stops below 5.4.53, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.41, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.4.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.13, so it looks safe — our inference, not a vendor statement
v < 5.4.53v < 6.4.41v < 7.4.13v < 8.0.13
Affected range stops below 5.4.53, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.41, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.4.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.13, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (5)

x_refsource_CONFIRMPatchVendor Advisory
Source: cverecord
https://github.com/symfony/symfony/security/advisories/GHSA-h5x3-xfc9-m39h
x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/symfony/symfony/releases/tag/v5.4.53
x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/symfony/symfony/releases/tag/v6.4.41
x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/symfony/symfony/releases/tag/v7.4.13

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-172CWE-601

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card