CVE-2026-48736

Symfony: IpUtils::PRIVATE_SUBNETS Omits IPv6 Transition Forms (6to4, NAT64, Teredo, IPv4-compatible): SSRF Bypass in NoPrivateNetworkHttpClient

HIGH
8.6
CVSS Score
Published: July 14, 2026 at 07:09 PM UTC
Updated: July 16, 2026 at 03:30 AM UTC
4 products affected across 2 vendorsSymfonySymfonyHTTP Client

Using symfony by symfony?

Get instant alerts when new vulnerabilities affect symfony - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.6
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. From 5.4.0 to 5.4.53, 6.4.41, 7.4.13, and 8.0.13, NoPrivateNetworkHttpClient and IpUtils::PRIVATE_SUBNETS omitted IPv6 transition prefixes such as 6to4, NAT64, Teredo, and IPv4-compatible IPv6, allowing attacker-supplied URLs to represent private IPv4 targets in forms that IpUtils::isPrivateIp() did not block. This issue is fixed in versions 5.4.53, 6.4.41, 7.4.13, and 8.0.13.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

5.4.0 ≤ v < 5.4.436.4.0 ≤ v < 6.4.417.0.0 ≤ v < 7.4.138.0.0 ≤ v < 8.0.13
Affected range stops below 5.4.43, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.41, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.4.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.13, so it looks safe — our inference, not a vendor statement
v < 5.4.53
Affected range stops below 5.4.53, so it looks safe — our inference, not a vendor statement
v < 6.4.41v < 7.4.13v < 8.0.13
Affected range stops below 6.4.41, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.4.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.13, so it looks safe — our inference, not a vendor statement
v < 5.4.53v < 6.4.41v < 7.4.13v < 8.0.13
Affected range stops below 5.4.53, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.41, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.4.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.13, so it looks safe — our inference, not a vendor statement

References (6)

x_refsource_CONFIRMPatchVendor Advisory
Source: cverecord
https://github.com/symfony/symfony/security/advisories/GHSA-38cx-cq6f-5755
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/symfony/symfony/releases/tag/v5.4.53
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/symfony/symfony/releases/tag/v6.4.41
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/symfony/symfony/releases/tag/v7.4.13

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-184CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card