CVE-2026-47262

containerd image-triggered runtime DoS via unbounded group parsing

MEDIUM
5.5
CVSS Score
Published: July 1, 2026 at 05:48 PM UTC
Updated: July 2, 2026 at 07:58 PM UTC
2 products affected across 2 vendorsContainerdContainerd

Using containerd by containerd?

Get instant alerts when new vulnerabilities affect containerd - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

containerd is an open-source container runtime. Versions prior to 1.7.33, 2.0.10, 2.1.9, 2.2.5 and 2.3.2, contain a vulnerability that allows a maliciously crafted image to cause a Denial of Service (DoS) condition. When creating a container from this image, memory exhaustion occurs, leading to an Out Of Memory (OOM) kill of the containerd process. This renders the container runtime API unavailable and can disrupt clients such as the Docker Engine or Kubernetes control-plane components. This issue has been fixed in versions 1.7.33, 2.0.10, 2.1.9, 2.2.5 and 2.3.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.7.0 ≤ v < 1.7.332.0.0 ≤ v < 2.0.102.1.0 ≤ v < 2.1.92.2.0 ≤ v < 2.2.52.3.0 ≤ v < 2.3.2
Affected range stops below 1.7.33, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.2.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.3.2, so it looks safe — our inference, not a vendor statement
v < 1.7.33v < 2.0.10v < 2.1.9v < 2.2.5v < 2.3.2
Affected range stops below 1.7.33, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.2.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.3.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card