CVE-2026-46529

PDF /GoToR action argv injection enables single-click RCE via --gtk-module dlopen

HIGH
7.8
CVSS Score
Published: June 10, 2026 at 07:46 PM UTC
Updated: October 26, 2026 at 11:10 AM UTC
3 products affected across 2 vendorsAtrilEnterprise LinuxDesktop Atril

Using atril by mate-desktop?

Get instant alerts when new vulnerabilities affect atril - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 0.5%
SSVC
PoC

Description

Atril Document Viewer is the default document reader of the MATE desktop environment for Linux. A single-click remote code execution vulnerability in versions prior to 1.26.3 and 1.28.4 allows an attacker to achieve arbitrary code execution as the user by tricking them into clicking a link inside a malicious PDF document. The PDF can be packaged as a polyglot file that is simultaneously a valid PDF and a valid ELF shared library, making the attack a single-file, single-click, configuration-independent RCE on stock atril installations. The root cause is `shell/ev-application.c:ev_spawn`, which builds a command line from attacker-controlled PDF link-destination fields without applying `g_shell_quote`. The cmdline is then handed to `g_app_info_create_from_commandline`, which shell-parses it back into argv — splitting any embedded `--gtk-module=PATH` into a separate argv element. GTK then `dlopen()`s the path during init, running any `__attribute__((constructor))` it finds. Versions 1.26.3 and 1.28.4 contain a patch for the issue. This is the same defect class as CVE-2023-51698 (CBT `--checkpoint-action` injection in `comics-document.c`, fixed in 1.6.2) but in a different code path (`shell/ev-application.c`) that the original patch did not touch.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

All versions
Affected range stops below 1.26.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.28.4, so it looks safe — our inference, not a vendor statement
v < 1.26.3v < 1.28.4
Affected range stops below 1.26.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.28.4, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 0:3.28.2-11.el7_9 (unaffected)
Vendor states this is fixed in 0:3.28.4-11.el8_4.1 (unaffected)
Vendor states this is fixed in 0:3.28.4-16.el8_6.1 (unaffected)
Vendor states this is fixed in 0:3.28.4-16.el8_8.1 (unaffected)
Vendor states this is fixed in 0:3.28.4-17.el8_10 (unaffected)
Vendor states this is fixed in 0:40.5-2.el9_2.1 (unaffected)
Vendor states this is fixed in 0:40.5-2.el9_4.1 (unaffected)
Vendor states this is fixed in 0:40.5-2.el9_6.1 (unaffected)
Vendor states this is fixed in 0:40.5-4.el9_8.1 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

References (21)

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.8HIGHredhat-SADP
Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-77CWE-88CWE-829

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card