CVE-2026-46334

OpenSIPS: Denial of Service in SDP bandwidth parsing via QoS SDP cloning

HIGH
8.7
CVSS Score
Published: August 4, 2026 at 11:50 PM UTC
Updated: September 8, 2026 at 08:59 PM UTC
1 product affected across 1 vendorOpenSIPS

Using opensips by OpenSIPS?

Get instant alerts when new vulnerabilities affect opensips - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.7
Exploit prediction
EPSS 0.7%
SSVC
PoC

Description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.6.6 and 4.0.0-rc1 contain a denial of service vulnerability in the SDP bandwidth-line parsing logic. A SIP request with Content-Type: application/sdp and a malformed session-level SDP bandwidth line missing the required colon delimiter can corrupt parsed SDP bandwidth metadata. When a route or module subsequently clones the corrupted SDP state, as occurs with dialog and QoS processing, the OpenSIPS worker process crashes. An unauthenticated remote attacker can therefore trigger a crash in any configuration whose routing script parses attacker-controlled SDP and applies dialog/QoS processing. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.6.6v < 4.0.0-rc1
Affected range stops below 3.6.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0-rc1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCPoCAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.7HIGHGitHub_M
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-476CWE-20

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card