CVE-2026-45810

Nextcloud: Propfind requests for file comments allowed to load comments for other files

MEDIUM
6.8
CVSS Score
Published: June 1, 2026 at 05:13 PM UTC
Updated: July 22, 2026 at 08:27 AM UTC
1 product affected across 1 vendorNextcloud/server

Using security-advisories by nextcloud?

Get instant alerts when new vulnerabilities affect security-advisories - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.8
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 31.0.0 to before 31.0.12, and 32.0.0 to before 32.0.3, a missing check of a relation allowed authenticated users with access to any file comment, to read the content of all comments. It is recommended that the Nextcloud Server is upgraded to 31.0.12 or 32.0.3. It is recommended that the Nextcloud Enterprise Server is upgraded to 21.0.9.20, 22.2.10.35, 23.0.12.31, 24.0.12.30, 25.0.13.25, 26.0.13.22, 27.1.11.22, 28.0.14.13, 29.0.16.10, 30.0.17.5, 31.0.12 or 32.0.3

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

21.0.0 ≤ v < 21.0.9.2022.0.0 ≤ v < 22.2.10.3523.0.0 ≤ v < 23.0.12.3124.0.0 ≤ v < 24.0.12.3025.0.0 ≤ v < 25.0.13.2526.0.0 ≤ v < 26.0.13.2227.0.0 ≤ v < 27.1.11.2228.0.0 ≤ v < 28.0.14.1329.0.0 ≤ v < 29.0.16.1030.0.0 ≤ v < 30.0.17.531.0.0 ≤ v < 31.0.1232.0.0 ≤ v < 32.0.3
Affected range stops below 21.0.9.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2.10.35, so it looks safe — our inference, not a vendor statement
Affected range stops below 23.0.12.31, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.0.12.30, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.0.13.25, so it looks safe — our inference, not a vendor statement
Affected range stops below 26.0.13.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 27.1.11.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 28.0.14.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 29.0.16.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 30.0.17.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 31.0.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 32.0.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_MISCIssue TrackingPatch
Source: cverecord
https://github.com/nextcloud/server/pull/56982
x_refsource_MISCPermissions Required
Source: cverecord
https://hackerone.com/reports/3425534

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.8MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-639

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card