CVE-2026-45282

Nextcloud: Logged-in user bypasses share password and download restrictions on Text attachments via documentId leads to unauthorized file access

MEDIUM
6.5
CVSS Score
Published: June 1, 2026 at 04:53 PM UTC
Updated: July 22, 2026 at 07:37 AM UTC
1 product affected across 1 vendorNextcloud/server

Using security-advisories by nextcloud?

Get instant alerts when new vulnerabilities affect security-advisories - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, an authenticated attacker can access attachments of link shares when knowing the share token, circumventing password protection or download restrictions. It is applicable to any file that is shared directly, as the attacker only needs to know a documentId they own, apart of the mentioned share token. For shared folders the attacker has to know or guess a documentId of a file that is included inside the folder, making it much harder to exploit. The attacker can only extract an attachments, but not the file shared file or folder itself. It is recommended that the Nextcloud Server is upgraded to 33.0.3 or 32.0.9. It is recommended that the Nextcloud Enterprise Server is upgraded to 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9, 29.0.16.16, 28.0.14.17 or 27.1.11.5

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

27.0.0 ≤ v < 27.1.11.528.0.0 ≤ v < 28.0.14.1729.0.0 ≤ v < 29.0.16.1630.0.0 ≤ v < 30.0.17.931.0.0 ≤ v < 31.0.14.532.0.0 ≤ v < 32.0.933.0.0 ≤ v < 33.0.3
Affected range stops below 27.1.11.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 28.0.14.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 29.0.16.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 30.0.17.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 31.0.14.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 32.0.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 33.0.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_CONFIRMMitigationVendor Advisory
Source: cverecord
https://github.com/nextcloud/security-advisories/security/advisories/GHSA-35fx-69q6-xpjr
x_refsource_MISCIssue TrackingPatch
Source: cverecord
https://github.com/nextcloud/text/pull/8499
x_refsource_MISCPermissions Required
Source: cverecord
https://hackerone.com/reports/3577244

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-284NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card