CVE-2026-45281

Nextcloud: Cross-Account Calendar Takeover via Unauthorized Group-Member-Set Update

HIGH
8.1
CVSS Score
Published: June 1, 2026 at 04:52 PM UTC
Updated: July 22, 2026 at 07:37 AM UTC
1 product affected across 1 vendorNextcloud/server

Using security-advisories by nextcloud?

Get instant alerts when new vulnerabilities affect security-advisories - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.1
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, with the knowledge of other users’ principal URL an attacker could possibly send a request to gain full access to their calendar. Therefore, the attacker must be an authenticated user. This is because of improper authorization controls in the backend of the calendar. If the attacker had access to the calendar, they would be able to view and modify it. It is recommended that the Nextcloud Server is upgraded to 33.0.3 or 32.0.9. It is recommended that the Nextcloud Enterprise Server is upgraded to 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9, 29.0.16.16, 28.0.14.17, 27.1.11.26, 26.0.13.26, 25.0.13.29, 24.0.12.34, 23.0.12.35, 22.2.10.39, or 21.0.9.23

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

21.0.0 ≤ v < 21.0.9.2322.0.0 ≤ v < 22.2.10.3923.0.0 ≤ v < 23.0.12.3524.0.0 ≤ v < 24.0.12.3425.0.0 ≤ v < 25.0.13.2926.0.0 ≤ v < 26.0.13.2627.0.0 ≤ v < 27.1.11.2628.0.0 ≤ v < 28.0.14.1729.0.0 ≤ v < 29.0.16.1630.0.0 ≤ v < 30.0.17.931.0.0 ≤ v < 31.0.14.532.0.0 ≤ v < 32.0.933.0.0 ≤ v < 33.0.3
Affected range stops below 21.0.9.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2.10.39, so it looks safe — our inference, not a vendor statement
Affected range stops below 23.0.12.35, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.0.12.34, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.0.13.29, so it looks safe — our inference, not a vendor statement
Affected range stops below 26.0.13.26, so it looks safe — our inference, not a vendor statement
Affected range stops below 27.1.11.26, so it looks safe — our inference, not a vendor statement
Affected range stops below 28.0.14.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 29.0.16.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 30.0.17.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 31.0.14.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 32.0.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 33.0.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_CONFIRMMitigationVendor Advisory
Source: cverecord
https://github.com/nextcloud/security-advisories/security/advisories/GHSA-hrrv-mp25-26vv
x_refsource_MISCIssue TrackingPatch
Source: cverecord
https://github.com/nextcloud/server/pull/59962
x_refsource_MISCPermissions Required
Source: cverecord
https://hackerone.com/reports/3545964

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.1HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-639

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card