CVE-2026-45077

Symfony: Unauthenticated PHP Object Deserialization in MonologBridge server:log Listener

HIGH
8.6
CVSS Score
Published: July 14, 2026 at 05:46 PM UTC
Updated: July 15, 2026 at 03:54 PM UTC
3 products affected across 2 vendorsSymfonySymfonyMonolog Bridge

Using symfony by symfony?

Get instant alerts when new vulnerabilities affect symfony - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.6
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, the server:log listener (Symfony\Bridge\Monolog\Command\ServerLogCommand) binds to 0.0.0.0:9911 by default and processes each received frame with unserialize(base64_decode($message)) without authentication, integrity checks, or an allowed_classes allowlist, allowing any reachable host to submit attacker-chosen serialized PHP payloads that can crash the listener and may trigger object-injection gadget effects. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.4.526.0.0 ≤ v < 6.4.407.0.0 ≤ v < 7.4.128.0.0 ≤ v < 8.0.12
Affected range stops below 5.4.52, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.40, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.4.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.12, so it looks safe — our inference, not a vendor statement
v < 5.4.52v < 6.4.40v < 7.4.12v < 8.0.12
Affected range stops below 5.4.52, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.40, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.4.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.12, so it looks safe — our inference, not a vendor statement
v < 5.4.52v < 6.4.40v < 7.4.12v < 8.0.12
Affected range stops below 5.4.52, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.40, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.4.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.12, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (6)

x_refsource_CONFIRMPatchVendor Advisory
Source: cverecord
https://github.com/symfony/symfony/security/advisories/GHSA-m7v2-7gxm-vc2v
x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/symfony/symfony/releases/tag/v5.4.52
x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/symfony/symfony/releases/tag/v6.4.40
x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/symfony/symfony/releases/tag/v7.4.12
x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/symfony/symfony/releases/tag/v8.0.12

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-502CWE-668

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card