CVE-2026-45004

OpenClaw < 2026.4.23 - Arbitrary Code Execution via setup-api.js in Current Working Directory

HIGH
7.8
CVSS Score
Published: May 11, 2026 at 04:46 PM UTC
Updated: June 17, 2026 at 10:51 AM UTC
1 product affected across 1 vendorOpenClaw

Using OpenClaw by OpenClaw?

Get instant alerts when new vulnerabilities affect OpenClaw - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 0.1%
SSVC
No known exploit

Description

OpenClaw before 2026.4.23 contains an arbitrary code execution vulnerability in the bundled plugin setup resolver that loads setup-api.js from process.cwd() during provider setup metadata resolution. Attackers can execute arbitrary JavaScript under the current user account by placing a malicious extensions/<plugin>/setup-api.js file in a repository and convincing a user to run OpenClaw commands from that directory.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2026.4.23
Vendor states this is fixed in 2026.4.23 (unaffected)

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.8HIGHVulnCheck
Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-427

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card