CVE-2026-44911

Apache NiFi: Incorrect Authorization for Configuration Verification Requests

MEDIUM
6.3
CVSS Score
Published: June 22, 2026 at 07:37 AM UTC
Updated: October 25, 2026 at 11:10 PM UTC
1 product affected across 1 vendorNifi

Using Apache NiFi by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache NiFi - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.3
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed configuration properties. The proposed properties override current configuration, enabling users with read access to invoke predefined verification methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying component configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, requiring write access to submit configuration verification requests.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.15.0 ≤ v < 2.10.01.15.0
Affected range stops below 2.10.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

Vendor AdvisoryMailing List
Source: cverecord
https://lists.apache.org/thread/wrj3t4k2bwd2cztyp078f5kj3722qfzy
Third Party AdvisoryMailing List
Source: af854a3a-2127-422b-91ae-364da2661108
http://www.openwall.com/lists/oss-security/2026/06/20/4

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card