CVE-2026-44849

Portainer: Endpoint security bypass via Swarm service create/update

HIGH
8.8
CVSS Score
Published: May 28, 2026 at 09:06 PM UTC
Updated: July 21, 2026 at 10:29 AM UTC
1 product affected across 1 vendorPortainer

Using portainer by portainer?

Get instant alerts when new vulnerabilities affect portainer - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, Portainer enforces seven EndpointSecuritySettings restrictions that administrators configure to restrict the container configurations non-admin users can launch: privileged mode, host PID namespace, device mapping, capabilities, sysctls, security-opt (Seccomp / AppArmor), and bind mounts. These restrictions are enforced on the standard container creation path, but several of them are not applied on the Docker Swarm service API. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.33.8v < 2.39.2v < 2.41.02.33.0 ≤ v < 2.33.82.34.0 ≤ v < 2.39.12.40.0
Affected range stops below 2.33.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.39.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.39.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.41.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

References (1)

x_refsource_CONFIRMExploitThird Party Advisory
Source: cverecord
https://github.com/portainer/portainer/security/advisories/GHSA-5fxq-qcf3-244w

SSVC — Action Prioritization

SSVCNo known exploitAutomatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-862

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card