CVE-2026-44541

Fides: DOM-based XSS vulnerability in fides.js via fides_description override

HIGH
7
CVSS Score
Published: June 8, 2026 at 08:01 PM UTC
Updated: July 23, 2026 at 07:32 PM UTC
1 product affected across 1 vendorFides

Using fides by ethyca?

Get instant alerts when new vulnerabilities affect fides - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7
Exploit prediction
EPSS 0.3%
SSVC
PoC

Description

Fides is an open-source privacy engineering platform. From version 2.33.0 to before version 2.84.5, there is a DOM-based XSS vulnerability in fides.js via the fides_description override. This issue has been patched in version 2.84.5.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.84.5
Affected range stops below 2.84.5, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7HIGHGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card