CVE-2026-44167

phpseclib: CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()

HIGH
7.5
CVSS Score
Published: May 12, 2026 at 05:22 PM UTC
Updated: June 17, 2026 at 10:50 AM UTC
1 product affected across 1 vendorPhpseclib

Using phpseclib by phpseclib?

Get instant alerts when new vulnerabilities affect phpseclib - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.0.29v < 2.0.54v < 3.0.52
Affected range stops below 1.0.29, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.54, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.0.52, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card